VKontakte больше «не дружит» с iOS 3.1.3 и ниже

16

Я пригласил вас, господа, с тем, чтобы сообщить вам пренеприятное известие: к нам едет ревизор. И имя того ревизора Павел Дуров, который принес сегодня печальную весть из Санкт-Петербурга, повествующую о прекращении работы сайта с браузером  iPhone OS 3.1.3 и ниже, который перестал работать с полной версией сайта vkontakte.ru.

Вчера вечером, мне позвонил друг и пожаловался на работу Safari в iPhone 2G с самый популярным в России сайтом. Встретившись с ним сегодня, он показал, что случилось.

Загружая vkontakte.ru, браузер переходит на главную страничку пользователя, после чего моментально перенаправляет вас по ссылке, ведущей сюда:

Насколько вы можете видеть, Вконтакте жалуется на то, что в телефоне установлена устаревшая версия Safari и предлагает скачать более новую, указывая на другие браузеры (!) десктопной версии. Главное в этом то, что сайт настаивает на том, что мобильная версия Safari не поддерживает движок JavaScript, хотя в действительности это не так.

Как мне кажется, в первую очередь это связано с тем, что не так давно Apple выпустила обновленную версию операционной системы iOS, где одним из важных нововведений стала поддержка совершенно нового движка JavaScript Nitro. Похоже, программисты Вконтакте взяли данную «плюшку» на заметку, и перевели работу сайта в ускоренный режим, используя этот самый движок.

Заинтриговавшись вопросом, я проверил данную «неприятность» и на других аппаратах с прошивками, ниже 4.0: к моему удивлению, сайт на некоторых аппарат работал, на некоторых – нет. Чем это объясняется, к сожалению, не понимаю.

Как от этого спастись?

Во-первых, помимо полной версии сайта существуют и другие:

i.vkontakte.ru – созданная специально для iPhone версия

m.vkontakte.ru – общедоступная мобильная версия сайта, «съедающая» более меньшее количество трафика

0.vkontakte.ru – бесплатная, облегченная до предела, версия Вконтакте, доступная лишь некоторым операторам России.

Во-вторых, помимо Safari в App Store можно скачать другие браузеры, работающие не на движке WebKit:

Opera (Free)

Skifire ($1,99)

Работает ли Вконтакте у вас? (Вопрос к пользователям iOS 3.1.3 и ниже)

 
Авторизуйтесь Чтобы оставить комментарий